Keyboard not working after installing vigembus on laptop.

On a laptop.
After I installed it, played with ps5 controller for a while with ds4 windows.

Then my laptop crashed and it took an extra long time for it to open, and only the mouse was working, shut off and restarted the laptop, and keyboard still wasn't working and mouse became laggy, but it's not laggy when using controller's touchpad, uninstalled Vigembus, and laptop restarted, and now the touchpad isn't working too, but a USB mouse does, what do I do?

Some other information, num-lock, caps lock, and one of the F-buttons, F9 I think, lights up when the laptop's starting, then it turns off.

ViGEmBus does absolutely nothing, zero, nada with any other pre-existing device so my best guess is you have to track down what else got recently installed.


Well, I installed DS4 windows first, and after 2 hours or so, I installed vigembus, I uninstalled them both w/USB mouse.

If this helps, this happened before, but I forgot about it like a dumbass, somebody told me to delete a specific driver, I think it was something in USB? And then it worked, just now I deleted a driver called USB ROOT hub v.3.0 or something like that, and after a restart, toucpad now works and numlock light is pernamently on in the keyboard, keyboard still doesn't work though.

Afterthat, I deleted all the USB port drivers and restarted my computer, spammed the keyboard and was only able to type 1 letter, h, and disable numlock before the keyboard stopped working again, though F1 did open file manager for some time before that stopped working too.

Should have mentioned that at the start, before I deleted any USB port driver, I didn't have a keyboard driver, after deleting and restarting, device manager showed me I have one now, I deleted it, without deleting thr driver software, and nothing happened.

if you are unable to help me, could you direct me to any forum that might? I'm really desperate.

Come on our Discord and it will be easier and faster to chat, share screenshots and advice etc.


Tried to, but when I do /apply member, thr bot tells me that the interaction failed.

What's your username on Discord?