Bluetooth device has stopped working after trying to uninstall

Hello,
I was using my DS3 controller with a USB connection, and it worked.
I was trying to uninstall everything related to the DS3 controller in order to try and install again and get the BT working. I was using the guide here:
https://vigem.org/projects/DsHidMini/How-to-Install/

I have a desktop, with a USB BT dongle from Baseus:
https://www.aliexpress.com/item/1005003656126341.html

I was trying to uninstall using the "Driver Store Explorer", so I deleted everything related to nefarius in there, including the ".inf" files (2, DS and filter).

Afterwards, things got problematic. My BT isn't working and under "Bluetooth and other devices" it's written under the "Generic Bluetooth Adapter" that there's an error with the driver.
Also under Device Manager, there's this error:
symbol.png And in properties it's "(code 32)" (my PC isn't in English so I'm not attaching a picture).
I of course tried to right-click and uninstall the driver, then reconnecting it and all, but it didn't work.

Under "Add/Remove Porgrams" I can still find this:
installation.png But cannot remove it, since the bluetooth isn't working as for now:
removeerror.png I'm pretty sure that if I'll get to uninstall it, it'll fix things up.

I use the BT adapter to connect my speakers, so they aren't working of course, basically my computer has no BT now.

I also noticed under "Bluetooth and other devices" that I have a driver problem under "CORSAIR Lighting Node CORE" but I don't know if it was there before or just now. Maybe it's related so I'm metionting it.
EDIT: I uninstalled an erroneous USB input device from device manager, and the Lighting Node CORE reintsalled itself and now is ok. (The BT problem remains)

Please help.

Thanks

Try to follow the "How to fix Bluetooth device error codes 19 & 39?" SECTION in the followimg page: Frequently Asked Questions about BthPS3

On another note, you definitely should not force remove drivers without knowing what they do.

On dshidmini's removal guide, it's specifically stated to only remove dshidmini drivers, not every Nefarius driver in the PC.

Removing drivers without knowing what they do can "break" your system in ways that are really difficult to solve. You could easily have ended with no keyboard/mouse working.

@kirian You're absolutely right, it was a stupid move by me.
I did as it's written in the FAQ you sent me, and now it works.

Thank you very much!

I'm thinking about retrying installing it (carefully) to try the wireless option, so I'll ask, after installing everything, how does the controller suppose to connect? Should I press the "PS" button and let it peer the same way it peers with a PS3?

If you are using both DsHidMini v2 and BthPS3 v2, and everything is working as it should,.then you:

  1. Plug the controller via USB, and by just doing this DsHidMini should "pair" your controller to the current BT's address
  2. Unplug the controller and turn it on. The controller will send a connection request to the last paired BT host address and then it connect to the computer

when this doesn't work, it's either because:

  • You are using mis-matched versions of DsHidMini and BthPS3 (DsHidMini v2 and BthPS3 v1 and vice-versa)
  • You are using a fake controller that is incompatible
  • The BT adapter is failing to start with BthPS3 (just check on device manager if everything seems well)

@kirian Thank you very much for all the help and saving my drivers