DsHidMini rtx3060 problem


I was using Scp for years on my old laptop and it was fine. Few days ago I've bought a new laptop (lenovo legion rtx3060 ryzen7 win10) and today I wanted to try installing DsHidMini. It was pretty easy, I followed the steps in the guide and my gamepad was working just great. Then I restarted windows and some wild shit started to happen.

It seems like something about drivers was changed and it went bad: my laptop doesn't see the gpu now. I can't open nvidia control panel (it just doesn't do anything if I try to) and device manager shows this https://imgur.com/a/uhfWbcT

I've uninstalled everything as said in the guide, but it didn't help. Tried to uninstall my gpu's driver and reinstalling it using clean install, it didn't change anything. I can't find anyone with the same issue here, so I guess it's not a common issue.

Please let me know if you have any ideas on how to fix this, because I've tried everything I could think about and it didn't help sadly. Thanks.

Don't use external image sites, just paste screenshots into your reply.

Show the details of the faulty devices, especially the Device stack property.


@nefarius thanks for the fast reply.
Here are the details, is that enough or do you need something else there?

3.png 2.png 1.png

Very interesting... show the dialog behind "Driver details" button as well please.

@nefarius interesting is not the word I'd use here haha 😄
Here they are

Very odd, nothing there indicates anything out of the ordinary.

What projects of mine did you install and which exact versions prior to this happening?

@nefarius it's a new laptop so no prior installs. I've used this guide (https://vigem.org/projects/DsHidMini/How-to-Install/) for the version 2.x.x (v2.2.282). Did everything listed there, gamepad was working fine both via usb and bluetooth. Then restarted pc and it all went down for some reason.

Try if uninstalling BthPS3 and rebooting changes anything.

@nefarius already did that, yeah. Uninstalled everything I could find related to DsHidMini, used driver store explorer too. Sadly didn't change anything.

Please share the file C:\Windows\INF\setupapi.dev.log (you can simply drag it into the post, if not, zip it up before).

@nefarius says I don't have enough priveleges for this action

@mozek you need to copy the file to Desktop or somewhere else before, the Browser most probably can't directly read from the system directory.

@nefarius did that, copied to desktop and still can't paste it here. The error message is displayed on this site, not from windows, so I guess I don't have a right to paste anything but images?

@mozek then compress it and attach the ZIP.

@nefarius same error.
Pasted all the text from txt into this sharing site https://ctxt.io/2/AABgWtkkFw , if you don't want to open it lmk if there's another way to share it, couldn't think of anything else

There's not a single hint of BthPS3 or DsHidMini in it and it ends with Section end 2021/09/14 13:38:17.992

Are you sure this is the right file? Did you turn on file extensions and it's named setupapi.dev.log ?

@nefarius yep, absolutely


Well, then something is seriously wrong with your Windows installation I've never seen before. Don't really know what to advise here other than a fresh installation. If it doesn't even log like it should be... It's pretty broken.

@mozek it gets even weirder now though. So I've tried updating drivers via Driver Updater in CCleaner. It found 13 drivers that needed updating, I've selected all of them and started the update. In a few seconds I've recieved BSOD. After restart I've installed every last one of them one by one, no errors now. Apart from one driver, that is installing just fine and the update is completed, but next time I scan for drivers that need update it shows up again. So maybe it's the one that is the problem?

Don't use trash like CCleaner please, get driver updates either directly from the manufacturer site or Windows Update, everything else is a cash grab since Windows Vista. Windows and manufacturers know best, not these shady "cleaning" tools.