Cannot setup CSR with Windows stack

I understand from the boss that cheap CSR radios will work, as long as you use the default Microsoft stack. However, when trying to do so I get an error message that prevents the installation. Is this a normal error and I should just get a different dongle?

Note: The CSR Harmony drivers work when installed, so the device itself is not broken.

many thanks,
RDP
3.PNG 2.PNG 1.PNG Capture.PNG

Get rid of the Harmony drivers, they are outdated and suck (see this) and simply let Windows download the working drivers from Windows Update.

@nefarius My apologies for not explaining clearly! The above errors are when I'm trying to install the windows drivers onto the "cleaned" (no CSR drivers installed) device! I've already learned that the CSR drivers need to go, only default Windows driver are going to work.

RDP

Show Screenshots of device manager with View / By connection

Dozo!

@nefarius Capture.PNG

Well, that will never work with that question mark, doubleclick it and go to Details and share the Hardware ID.

Right click, uninstall and tick Remove software and let it refresh and it still doesn't work?

@nefarius Just tried (again!, I've tried that many times), and it just comes back with the same error as my first post:

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

The "net" says I need to disable SIP and other crap to make this work (Error 52).... very puzzling....

RDP

Get Driver Store Explorer (Google) and share the list of stuff you have installed, something ain't right on this machine, for this Hardware ID the integrated drivers shipped with Windows should work perfectly fine.

@nefarius Yes, I've already tried to help myself by going through your old clean up docs, and I think my system is clean, but please, see below, I might have missed something.

Note: I've also tried to remove the high and low filters for the CSR device PID, but nothing was in Regedit, and also something within the classes, https://doublerock.blogspot.com/2016/08/windows-7-cambridge-silicon-radio.html
, but, it didn't change the base issue.

RDP

New1.PNG

new2.PNG

.