ViGEm installed but not showing up in Device Manager

I have a new laptop that seems to have a problem with the installation of the Vigem Bus driver.

On my new machine, when I have DS4Windows running my controller turns of the Backlight when I switch between tasks. It also infrequently softlocks when it goes into rumble and keeps rumbling until I disconnect it. This happens with Steam games as well as emulated ones. So I suppose it's not due to the program the controller is used for.

I figured this would be a problem with the driver so I compared the devices shown in device manager to the ones on my old laptop where DS4Windows worked fine. I found that on my old device whenever DS4Windows is running I see a device named Virtual Gamepad Emulation Bus (see pic)2.png

On my new Laptop I instead see an XBOX 360 Peripheral Device wether DS4Windows is running or not. Instead it shows when the Controller is connected.4.png

Whenever I launch DS4Windows it asks for admin rights. It also frequently asks for admin rights mostly randomly when running for some time as if trying to implement the driver. I have the driver installed on both devices as seen in the Apps section under Windows settings. Is this switching on and off of the backlight of my controller and it's random rumble softlocks connected to this? Is this a known issue? I couldn't find an answer to this so I am asking. Thanks in advance.

The first screenshot is showing "View -> Devices by connection", the second is showing "View -> Devices by type".

Change the second view mode to devices by connection and then try finding the "(Nefarius) Virtual gamepad emulation bus"

@kirian Oh, right! I have checked and you are correct so ViGEm is installed and working identically on both devices. So I can rule that out as a cause. Thanks!

However, the backlight and rumbling issues are still not solved... Any idea what else could cause this? I have checked with the laptop that works properly and it does not show the XBOX 360 peripheral-device even when the controller is connected. Could it be that this driver somehow tries to hijack the controller whenever rumbling is active or when the task is switched? I honestly have no idea what else could cause this.

Short update: I have followed the complete full clean section until the last step to remove the driver completely then reinstalled it. Issue persists.

Additionally I have the information from the admin rights request DS4Windows sends everytime I restart it. It gives me this:

"C:\Users\Username\Documents\DS4Windows\DS4Windows.exe" re-enabledevice hid\vid_054c&pid_05c4\7&c4074cd&6&0000

It asks for this everytime, which it does not on the Laptop it's working on.

Also I have tried changing the name of this Topic since it does not represent the issue at hand. Couldn't edit it. Should I open a new one?

@uberspringer said in ViGEm installed but not showing up in Device Manager:

Also I have tried changing the name of this Topic since it does not represent the issue at hand. Couldn't edit it. Should I open a new one?

You can change the topic name if you edit the title of your first post.


@uberspringer said in ViGEm installed but not showing up in Device Manager:

"C:\Users\Username\Documents\DS4Windows\DS4Windows.exe" re-enabledevice hid\vid_054c&pid_05c4\7&c4074cd&6&0000

This is most probably because the command needs access to a registry section that only Administrators have write access to. Ugly but makes sense, it's an issue with the good old HidGuardian design. Why not more users have that issue I can not tell you, I don't use HidGuardian since... ever 😛


@nefarius @uberspringer The HigGuardian admin' prompt appears as HidGuardian Helper or something like this. DS4Windows never directly tries to mess with HidGuardian besides asking for HG access once when being launched.

The prompt the user is having I think is related to the hide DS4 controllers option being enabled on DS4Windows' Setting tab. Try disabling this option and the admin prompts should stop happening.

This option is used to prevent the "double input" issue, but it's a "legacy" feature in a sense that it can fail to work for many reasons and is not recommended to be used anymore. HidHide should be used in its place.

An explanation on the double input issue, HidHide and why the Hide ds4 controllers option is not recommended can be found on the Preventing the double controller / double input issue in games guide

EDIT 1: I remember that the Hide ds4 controllers option sometimes required admin rights but I can't replicate it anymore, so I don't know if it's actually the cause of the admin prompts.

@nefarius Tried that. It tells me I can't edit posts after a certain amount of time has passed...

@kirian I have unckecked the hide Controller option and the prompts are indeed gone. Unfortunately Hidhide is not running properly. Whenever I click on the Devices tab it tells me that "something unforseen has happened which cannot be recovered from..." then terminates...

Also no changes on the backlight/rumbling issue.

Okay, I have sorted it out. I followed the steps described here:

Also I have added DS4Windows to the exceptions-list in the Windows-Firewall under Firewall and Network-Protection.

This has made the "Hide DS4 Controller" Option viable.
The HidHide Configuration Client still gives me the error mentioning "Something unforseen..." but since it's working now I don't really mind.