SCP Toolkit removal guide resulted in broken bluetooth and gamepad driver

I followed the SCPToolkit manual removal guide (v. 1.6.x, Win 10 H) with the result that my default bluetooth driver (Intel Dual Band Wireless-AC 3165) has this error in Device Manager:

This device cannot start. (Code 10)
STATUS_DEVICE_POWER_FAILURE

There is another issue with Win 10 not recognizing my (fake) ds3 as a generic " PS3 gamepad", as it does on my clean laptop, but that is low priority.

Let me walk through what I did in order. Following the removal guide (in elevated powershell):

  1. taskkill: ScpTrayApp was the only one running.
  2. sc stop/delete: neither returned text.
  3. Add/remove programs: ScpToolkit (was this a mistake?)
  4. DriverStoreExplorer packages deleted: (I assumed there were 3 bthdongles because I had plugged my (fake) ds3 into different USB ports over time))
oem25.inf - scpvbus.inf
oem29.inf - ds3controller_1055536c-9223-4a51-bfa7-11dcef94d84d.inf
oem30.inf - bthdongle_c76ee840-c43b-4fb1-bd21-c8367df0f3a8.inf
oem39.inf - bthdongle_0209c545-347d-41a7-ab32-6245c72dc795.inf
oem40.inf - bthdongle_7183a36b-22ab-492b-996e-7f817e63b92f.inf
  1. Device Manager: no libusbK folder, nothing named SCP anywhere, so did nothing.
  2. DID NOT delete program files folder (missed that step).
  3. On reboot bluetooth failed in device manager. Verified SCP drivers were gone with DevManView.
  4. Uninstalled bluetooth (would have been v.20.x, not the new version) in device manager (probably did not check "delete files"). Maybe rebooted (would have been prompted if "delete files" were checked, otherwise not).
  5. If rebooted, would have seen native attempt at finding bluetooth hardware fail in some way. Not sure what happened, but see below for what happens now. Installed new bluetooth drivers downloaded from Intel site. Rebooted.
  6. Power failure error as above. In Win 10 bluetooth settings GUI, says "driver error" and confirms bluetooth device detection fails.
  7. Re-checked guide and saw I forgot to delete Program Files folder. Did that, problem persists.
  8. Uninstall drivers when deleting files and rebooting results in Windows detecting bluetooth hardware as "unknown device" with a driver error when installed. Installing/repairing Intel drivers turns that device into bluetooth in Device Manager.

What I notice in DriverStoreExplorer, under Bluetooth, there are 11 itusb.inf files listed: 7 are v. 22.30.x (the new driver), 2 are 20.100.x, 1 is 19.60.x, and 1 is 19.40.x (old drivers? V. 19.x is dated to when the PC shipped). When I uninstall bluetooth in Device Manager, with or without deleting files, only the 7 v. 22.x files are removed in DSE.

I am wondering if there is a way to fix this issue short of a Win reinstall. Any help would be appreciated.

Mate, just share screenshots of Driver Store Explorer, a picture tells a thousand words 😁

So far it has never been required to wipe Windows, all of these cases can be repaired, the people who wiped Windows came to me for consultation after wiping their disk, well, big brain move I can't help with 😅

Cheers

Well, I'd say it's just a picture of words, and at most 200.

driverstoreexplorer-2021-03-31.png

I'd say just toss out all those Bluetooth INFs, they're 3rd party anyway so nothing bad can happen, then grab the official all-in-one installer from Intel and run it, that should typically put everything on your machine you need for WiFi and Bluetooth.

EDIT: more direct link.

It works now, I think, but here's why wifi and bluetooth IT feels like voodoo to me:

I deleted all the bt drivers and reinstalled and it didn't work. So I tried installing the updated Intel wifi driver too (since it's for the same hardware) and reinstall bluetooth on top of that, no results. But checking DSE in between showed the bluetooth installation seemed to uninstall the new wifi drivers! Reinstalling wifi did nothing, but then I tried to reproduce what happened with bluetooth and couldn't. But then the next time I uninstalled the bluetooth driver and then force-deleted all the bluetooth drivers in DSE and then rebooted, my desktop background turned from plain black to green noise and everything had a green tint. Usually that's a video problem, so I checked the monitor (menu and boot normal), cable, vid card (driver could use updating but didn't see the issue listed on the driver site), cleaned dust (a little bit but no heating, fan noise, etc.), etc., nothing changed. THEN I reinstalled the bluetooth driver and rebooted, and... bluetooth works, and screen is back to normal. Hopefully it lasts.

So yeah, it's voodoo to me. Though I know you have a deeper understanding of how these drivers work and maybe you have an idea of what the heck was going on. Regardless we all appreciate you doing this kind of support.

Here's my final (working) DSE shot. It's actually identical to what DSE showed in the first two steps of this post (deleted all the bt drivers, reinstalled bt, updated wifi), since I screenshotted that too.
dse-2021-03-31-newinteldrivers-working.png

Great news! 😁 And yeah, computers can be weird sometimes. I assume there was some conflicting clutter left in the registry causing conflicts. We will never know I guess 😅

Cheers

@nefarius OK it looks like there are still problems with my bluetooth, because both my headset and controllers are stuttering after connecting. I had previously only tested that they connected and worked, and hadn't used them since then. The headset has been tested on my phone and laptop and works without stutter there, and the controller seems to not stutter on my laptop as well. The headset is new but the controllers are old and did not stutter prior to this whole uninstallation process. The only drivers changed since last week I believe are an updated graphics card driver and those pairing with the headset. Any ideas on how to proceed would be appreciated.

dse-2021-04-09.png