Having trouble with FireShock

So I just recently had to reformat my HDD and in doing so decided to upgrade to Windows 10 from Windows 7. Before I always used SCPToolkit so I tried to do that on Windows 10, just could not for the life of me get it to work. Did some digging, found out FireShock works with Windows 10 and is basically the successor to SCPToolkit. I was excited as I love playing with my PS3 controller. I installed everything needed (very simple to do, awesome) and then restarted my computer. Launched Shibari Dom Server, I see my controller stops blinking and registers as controller 1. The problem seems to be that the Shibari.Dom.Server service runs, but then I don't get the lines that should appear as connecting to my PS3 controller and whatnot, and Steam still doesn't recognize anything. Any suggestions?

if you install shibari as a service, then it'll start with the computer, and not show any UI, just output to the log file.

so it should just work on boot without any intervention.