Driver Installer Fails

I am trying to run the ViGEmBusSetup_x64.msi file and at the end of the setup wizard I get a prompt that it could not install. However, Windows 10 gives me a prompt that it needs to reboot. Any help is greatly appreciated.

OS: Windows 10 Pro 64 bit.

27089ad1-1488-4e81-9b16-c59736182d36-image.png

Well... did you reboot? What happens if so?

Cheers

@nefarius

After the reboot it had 4 entries in device manager under system devices but didn't show up in the control panel in the add/remove programs.

After some fiddling I manually removed the 4 entries in device manager and attempted to reinstall again. This time the setup says it completed. Will do some further testing later.

Ah I see, so you had multiple device nodes, yeah that is problematic but easy to fix. I see if I can do something about it in a newer release. For now glad it worked ☑

I get the same error when trying to install the drivers on Windows 10 insider preview build 21286 (ARM64) VM running using Parallels 16 on a Macbook pro M1. Any ideas on how to get the drivers to install? I really want to use DS4windows and i'm stuck because I cant install the drivers. Is there an ARM64 version? Many thanks for your help, truly appreciate all the hard work you've put into this project!!

Capture.PNG image url)