Help! DS3 wireless disconnects with Shibari after a random amount of time.



  • So, i have an "aftermarket" DS3 controller that i paired with a bluetooth dongle and used it with Shibari. it managed to work well with no issues until it suddenly started disconnecting randomly.

    Now everytime i reboot my pc or shut it down, it always works for 10-20 minutes before it starts disconnecting. then i can't make it connect again even if i re-open shibari and/or re-plug my dongle.

    The way it disconnects is that i suddenly hear the disconnected USB sound and the controller stops working. after that it takes about maybe 10 seconds before the Player 1 LED light goes out. when checking Shibari, this is what i saw :

    24802fec-7b32-45b0-af60-de4988841dd1-image.png

    if you need any other information please let me know.



  • Uh, silly question; is the battery maybe low? Do you charge the controller regularly?

    Cheers



  • @nefarius Uhhh no i don't think its a battery issue. not only did i leave it to charge for over 2 hours, but it also is, like i said, completely random. yesterday, it happened after 10 minutes, then after rebooting, it happened after 1 hour.



  • Hm, odd, I have no logic in there that would drop the connection other than the user powering the device off. I'm afraid I haven't much to recommend for now on this case 😬

    Cheers



  • @nefarius I see. i've had a theory that maybe its the software thinking that my controller is idle and auto-disconnecting it but that doesn't explain why its random. thanks anyways. hope your development for the Shibari replacement goes smoothly 😄



  • It does! So far it already surpassed the Shibari feature set. Sort of a dev-log is on the Discord 😉


Log in to reply