BthPS3 input inconsistencies. Works with MotionInJoy

I have 4 controllers all working with BthPS3 and I find it very slick to use and configure. However while using the controllers, I've noticed a strange inconsistent flick of the right stick during play. Its more than the deadzone would control for and it's as if I've flicked the stick very quickly. One of the official controllers also rumbles very late and for way too long while using BthPS3.

I know that the post-setup instructions say "this isn't and never was a software issue" and I believe it, but coincidently, it happens on all 4 controllers (3 legit and one very convincing fake). None of this happens when I revert back to MotionInJoy 🤢 *huack spit*.

These issues were present in SCP Toolkit. I've tried BthPS3 on 3 PC's with 2 different Bluetooth adapters and by directly connecting to USB with SCP. I've tried nuking and reinstalling, I've tried fresh installs on a system where MotionInJoy and SCP never existed. I've opened the controllers and cleaned them. I'm not using any other software that could be intercepting the inputs.

Is there some way for me to adjust for this? Are there logs I should be monitoring? Is it possible MotionInJoy accounts for these inconsistencies in some way by ignoring irregular input spikes? Should I just accept my controllers are malfunctioning and buy a new one, or suck it up and use motioninjoy?

Once again: BthPS3 has nothing to do with the input and output of the controller, it handles the connection to Windows, nothing more, nothing less. Those issues are Shibari business and possibly there's some overlooked hack or trick that MIJ accounts for but I don't know of that and don't have the capacity to go after that so I can't really recommend any solution at this point in time.

TL;DR: It is what it is 😎


I tried again after the recent Shibari update. It totally solved the jumpy analog stick issue.


Good riddance MIJ 🚽

Cool! I totally forgot about that weird case where some controllers send malformed packets in between. Filtered that out and seems to work like a charm 😀