Manually unblock Shibari archive



  • Windows by default recognizes files downloaded from the Internet and puts a "flag" on them causing warning dialog boxes and other weird "security" shenanigans to appear. Shibari doesn't like that. This flag needs to be removed before the archive is extracted and Shibari executed! Here's how:

    Unblock the archive by right-clicking on it, choosing Properties and ticking the Unblock box:

    d4a1ccff-934f-4b9e-9d34-cf30673eca6a-image.png

    After confirming with OK it's safe to extract the srchive contents somewhere on your machine (e.g. to C:\Shibari).

    That's it!



  • @nefarius Interestingly, It's possible for the zip to be blocked but without being displayed as such in the properties.

    It happened to me before I moved the archive to the desktop and was able to extract it properly... If you select the "save as" option - at least on MS Edge - not sure about other browsers, the zip archive doesn't get shown as blocked in the properties although it seemed to be (unless the issue was merely caused by the filesystem on the flash drive all along)



  • @dissectionalone the annoying thing is; the ZIP itself carrying the flag doesn't matter really, but the common extraction utilities like the built-in file exporer or even 7-Zip honor this flag and replicate it to all extracted files and when .NET detects a DLL "from the Internet" it will - in this case since I use it as a plugin system - silently not load them and the user is left with an "empty" application not doing anything.

    I have turned this off on my machines by default 😇


Log in to reply