BthPS3 & Post-Setup Instructions problem

I am a rookie so I did not undestand half of what you did but tried to do so (only the powershell thing without extracting the driver because I know clearly nothing about that) But it did not worked, it was to be expected I did 1/2 the job.

Even if the bluetooth driver was installed, my real problem after that will be the usb driver not working too, it's not a big deal, I'll take my time and wait for a W10 LTSC 1903 (if it ever happen), meanwhile I'll reuse Scp toolkit.
Thank you for your help 🙂

I've just noticed that my Lenovo IdeaPad Craptop runs on 1809 still and it works, but I have to admit I had to do multiple installs for some reason. Maybe because of the Intel Integrated Card or some other weird reason, can't really put my finger on it. Since it works at least in one case I for now decided to not kick 1809 compatibility from the setup. Just so you know ☺

i think windows 10 version has nothing to do with this problem.
here are list of checklists for my setup :

  1. make sure you have a bluetooth 4.0 or higher dongle or on board dongle (laptop), DO NOT USE a cheap 4.0 CSR bluetooth dongle - it does not work !

like this :
da1fb206-80ec-4f01-a05f-904a2cf2c702-image.png or this
9dd7e820-c327-43b3-9d98-faf36bc289a3-image.png or this

i have two of those, and all did not work for connecting to shibari

instead use this dongle :

TP-Link Bluetooth 4.0 Dongle USB Nano UB400 Adapter PC

  1. Remove all third party bluetooth driver such as BLUESOLEIL, just use plug and play driver from Windows 10

  2. make sure your dongle is working and shown in device manager

  3. follow the instruction guide for installing
    pre setup :
    post setup :

  4. just turn on your PS3 controller, connect to usb cable first, wait until recognized by shibari and then disconnect the cable from ds3 controller, wait until connected by bluetooth (you can do this many times until it says connected by bluetooth, this process is one time, unless you paired your ds3 controller to another machine and want to go back to your first machine) - and wait a moment until the led stop blinking and only 1 led is turn on

even when you shutdown or restart the computer/laptop, it is still recognized. no need to pairing again, just press the ps button on the controller, wait for a moment, until the led stop blinking (sometime you must press again in case all the leds are stop blinking/not paired)

note : if you are using shibari as a service, make sure shibari is started, or restart the service, or maybe you can make shibari automatic start (delayed) in services.

ok , thats what i do in my setup
I hope can help anyone .


Nice information, I thought my cheap bluetooth dongle was the problem (but it still work with Scp).

Even if switching dongle is the solution, I will still have Fireshock not working, as you can see in a screenshot above, under nefarius usb device, I don't know why, and the Usb is a must for charging the controller at least.

Thank you, I will try it someday when I'll have money to spend

@cnrez thanks for your contribution. I might add that I literally only used these cheap CSR nano dongles across multiple systems, even Windows 7 and it works. The way BthPS3 operates in theory is fairly hardware independent because I only consume official Microsoft DDI APIs. But then again, there are literally millions of slightly different systems out there, if the bulk works and we can uncover more along the way I'm satisfied ☺

@Edouard your case we could look into more carefully but not before 2020, at least not me personally.

I am in no hurry, rest well and have a wonderful holiday

@nefarius thank you master nefarius,
yes , i guess my system configuration is not compatible or maybe my usb dongle is not a good quality.
in my country those CSR dongle cost only around usd $2 - $3
i tried connecting again today with that CSR dongle, still not connected, i have not tried on other machine or blank windows 10 installation, may be it will works.

note : in my country, fake ds3 controller (wireless) is around usd $3.75,
instead fake xbox 360 wireless controller is around usd $25.05 + dongle xbox360 usd $13.53

thanks again for your software
i am very satisfied and i will tell my friend to use this software and ds3 controller. 👍

@cnrez glad it's of use, especially when you're on a tight budget. I'm really interested in feedback of working aftermarket devices. I'll also provide a "how to debug the driver" guide document so anybody will be able to see what's happening under the hood (in 2020) 😉



I know this post is old but I did find how to make it work despite being on W10 LTSC that is why I post in case if anyone have the exact same problem.

The problem was the driver they gave me (shipped with the dongle in a little disc) with my bluetooth dongle, as you can see in an upper screenshot from December 2019, I only had "CSR radio bluetooth" opposed to everyone else having the windows drivers that I have now ! (minus the nefarius of course).magic.png

If anyone have the same exact problem as me, it's simple, just uninstall the shitty CSR driver, insert the CD, the installer is a uninstaller too so nothing to explain here.

After that I did go in this page(I don't know the english name sorry), and choosed the 1st option to search for new modification on the hardware and boom it did install me the windows bluetooth driver. pick 1st.png

And the bluetooth I had was a cheap one the same as the screenshot of cnrez, you can see the disc under it too, and after installing everything work, usb and bluetooth, I have just one problem I did now saw in the Q&A, but I think I'll do another post for it.

Have a nice day 🙂