BthPS3 & Post-Setup Instructions problem



  • Well, BthPS3 isn't installed and the USB device driver has a serious issue. Open that with the exclamation mark and post details.



  • SOMETHING.png

    I use a bluetooth dongle csr 4.0, I hope it's compatible

    +add infos
    something2.png



  • In the installation folder there should be an install.log file, post the contents pls



  • I can't read the localized error message, sorry.



  • And if it's really an issue with 1809 I'm afraid I can't help you other than recommend to upgrade, see here for a similar case.



  • Installation folder ?

    If you are talking about BthPS3 it was just a .exe and is on my desktop, no install.log so far there
    if it's for shibari/vigem/fireshock I found none too

    I can change my language to english and repost the newer screenshot



  • C:\Program Files\Nefarius Software Solutions\BTH... look there



  • I can not link it here, so I'll copy/paste and add (for translation)

    Driver installed successfully
    BluetoothSetLocalServiceInfo failed, error: Aucune donnée n’est disponible.(No data is available)

    Service created successfully
    Filter enabled. Reconnect affected devices or reboot system to apply changes!
    Failed to disable Bluetooth host device, error: Aucune donnée n’est disponible.(No data is available)

    Driver installed successfully
    Couldn't open control device, error: Le fichier spécifié est introuvable.(The specified file is Not found)



  • Yeah install is f'ed up, no idea why and I don't have the capacity to deal with older Windows builds troubleshooting, sorry.



  • As I thought it's my 1809 build, ah lucky me.
    Thank you for your support 🙂



  • "WDYM by no DInput, when Shibari outputs a virtual DS4 you literally get a dinput compatible device."

    Sorry I did not respond earlier, what I meant was, I only know of shibari who "give me Dinput" all the others alternatives for making my ds3 work on Windows always use Xinput, thus having a lot of Xbox unwanted prompt in some ds4 compatible games, I don't know if I sound clear in my explanation



  • Same thing happen to me and my Windows is up to date.
    Here is how i resolve issue.
    https://forums.vigem.org/topic/366/bthps3-installation-troubles



  • I am a rookie so I did not undestand half of what you did but tried to do so (only the powershell thing without extracting the driver because I know clearly nothing about that) But it did not worked, it was to be expected I did 1/2 the job.

    Even if the bluetooth driver was installed, my real problem after that will be the usb driver not working too, it's not a big deal, I'll take my time and wait for a W10 LTSC 1903 (if it ever happen), meanwhile I'll reuse Scp toolkit.
    Thank you for your help 🙂



  • I've just noticed that my Lenovo IdeaPad Craptop runs on 1809 still and it works, but I have to admit I had to do multiple installs for some reason. Maybe because of the Intel Integrated Card or some other weird reason, can't really put my finger on it. Since it works at least in one case I for now decided to not kick 1809 compatibility from the setup. Just so you know ☺



  • i think windows 10 version has nothing to do with this problem.
    here are list of checklists for my setup :

    1. make sure you have a bluetooth 4.0 or higher dongle or on board dongle (laptop), DO NOT USE a cheap 4.0 CSR bluetooth dongle - it does not work !

    like this :
    da1fb206-80ec-4f01-a05f-904a2cf2c702-image.png or this
    9dd7e820-c327-43b3-9d98-faf36bc289a3-image.png or this
    132bef67-a00a-47b0-ab95-a34b577197ae-image.png

    i have two of those, and all did not work for connecting to shibari

    instead use this dongle :
    38f07786-13d8-4c0d-9b4d-4ffd5813848c-image.png

    TP-Link Bluetooth 4.0 Dongle USB Nano UB400 Adapter PC

    1. Remove all third party bluetooth driver such as BLUESOLEIL, just use plug and play driver from Windows 10
      http://www.bluesoleil.com/products/S0001201005190001.html

    2. make sure your dongle is working and shown in device manager

    3. follow the instruction guide for installing
      pre setup :
      https://forums.vigem.org/topic/362/playstation-r-3-peripherals-unofficial-bluetooth-drivers-bthps3
      post setup :
      https://forums.vigem.org/topic/357/bthps3-post-setup-instructions

    4. just turn on your PS3 controller, connect to usb cable first, wait until recognized by shibari and then disconnect the cable from ds3 controller, wait until connected by bluetooth (you can do this many times until it says connected by bluetooth, this process is one time, unless you paired your ds3 controller to another machine and want to go back to your first machine) - and wait a moment until the led stop blinking and only 1 led is turn on

    even when you shutdown or restart the computer/laptop, it is still recognized. no need to pairing again, just press the ps button on the controller, wait for a moment, until the led stop blinking (sometime you must press again in case all the leds are stop blinking/not paired)

    note : if you are using shibari as a service, make sure shibari is started, or restart the service, or maybe you can make shibari automatic start (delayed) in services.

    ok , thats what i do in my setup
    I hope can help anyone .

    cheers



  • Nice information, I thought my cheap bluetooth dongle was the problem (but it still work with Scp).

    Even if switching dongle is the solution, I will still have Fireshock not working, as you can see in a screenshot above, under nefarius usb device, I don't know why, and the Usb is a must for charging the controller at least.

    Thank you, I will try it someday when I'll have money to spend



  • @cnrez thanks for your contribution. I might add that I literally only used these cheap CSR nano dongles across multiple systems, even Windows 7 and it works. The way BthPS3 operates in theory is fairly hardware independent because I only consume official Microsoft DDI APIs. But then again, there are literally millions of slightly different systems out there, if the bulk works and we can uncover more along the way I'm satisfied ☺



  • @Edouard your case we could look into more carefully but not before 2020, at least not me personally.



  • I am in no hurry, rest well and have a wonderful holiday



  • @nefarius thank you master nefarius,
    yes , i guess my system configuration is not compatible or maybe my usb dongle is not a good quality.
    in my country those CSR dongle cost only around usd $2 - $3
    i tried connecting again today with that CSR dongle, still not connected, i have not tried on other machine or blank windows 10 installation, may be it will works.

    note : in my country, fake ds3 controller (wireless) is around usd $3.75,
    instead fake xbox 360 wireless controller is around usd $25.05 + dongle xbox360 usd $13.53

    thanks again for your software
    i am very satisfied and i will tell my friend to use this software and ds3 controller. 👍


Log in to reply