BthPS3 & Post-Setup Instructions problem


  • Hello,

    I did follow all the installation process, making sure to have my vanilla bluetooth drivers, uninstalling scp toolkit
    and having Windows 10 up to date, carefully reading what to do in order to not missing something important.

    Everything seems to install itself fine no error prompt or something like that, but when I launch Shibari.Dom.server.exe (after installing FireShock and ViGEm) my controller is not being recognised nor by bluetooth nor by usb.

    So my real question here is : Does W10 LTSC 1809 is the problem ?
    I use a real DS3 sixaxis Sony controller.

    I do not know if linking an URL is accepted but here is a screenshot of my Shibari window with the controller plugged in
    https://i.imgur.com/QA1yfDV.png


  • Unfortunately I can't even get that far. Followed the instructions to a T. Also using LTSC 1809 for what it's worth. Opening Shibari.Dom.Server.exe crashes immediately, opened it up in CMD to see if anything I missed and sure enough some error is happening.
    https://i.imgur.com/z5AmCWN.png


  • I've had negative feedback from users of "older" builds of Windows 10 indeed, might very well be, sorry!


  • I am so sad, you were my only chance to have Dinput instead of Xinput with my DS3 controller (If I am not mistaken you are the only one who developed softwares for this specific need)

    Well... let's go back to Xinput, and thank you a lot for what you did, even if I can't use it now, Have a nice christmas !


  • @Edouard your case looks different. Please post a Screenshot of Device Manager, if Shibari doesn't pick anything up it's 99% one of the required drivers not installed properly. Expand the Bluetooth node.

    WDYM by no DInput, when Shibari outputs a virtual DS4 you literally get a dinput compatible device.

    Cheers

    Also you don't need to use that sh*t imgur, just paste the screenshot directly into your reply box 🤘


  • Device manager.png


  • Well, BthPS3 isn't installed and the USB device driver has a serious issue. Open that with the exclamation mark and post details.


  • SOMETHING.png

    I use a bluetooth dongle csr 4.0, I hope it's compatible

    +add infos
    something2.png


  • In the installation folder there should be an install.log file, post the contents pls


  • I can't read the localized error message, sorry.


  • And if it's really an issue with 1809 I'm afraid I can't help you other than recommend to upgrade, see here for a similar case.


  • Installation folder ?

    If you are talking about BthPS3 it was just a .exe and is on my desktop, no install.log so far there
    if it's for shibari/vigem/fireshock I found none too

    I can change my language to english and repost the newer screenshot


  • C:\Program Files\Nefarius Software Solutions\BTH... look there


  • I can not link it here, so I'll copy/paste and add (for translation)

    Driver installed successfully
    BluetoothSetLocalServiceInfo failed, error: Aucune donnée n’est disponible.(No data is available)

    Service created successfully
    Filter enabled. Reconnect affected devices or reboot system to apply changes!
    Failed to disable Bluetooth host device, error: Aucune donnée n’est disponible.(No data is available)

    Driver installed successfully
    Couldn't open control device, error: Le fichier spécifié est introuvable.(The specified file is Not found)


  • Yeah install is f'ed up, no idea why and I don't have the capacity to deal with older Windows builds troubleshooting, sorry.


  • As I thought it's my 1809 build, ah lucky me.
    Thank you for your support 🙂


  • "WDYM by no DInput, when Shibari outputs a virtual DS4 you literally get a dinput compatible device."

    Sorry I did not respond earlier, what I meant was, I only know of shibari who "give me Dinput" all the others alternatives for making my ds3 work on Windows always use Xinput, thus having a lot of Xbox unwanted prompt in some ds4 compatible games, I don't know if I sound clear in my explanation


  • Same thing happen to me and my Windows is up to date.
    Here is how i resolve issue.
    https://forums.vigem.org/topic/366/bthps3-installation-troubles


  • I am a rookie so I did not undestand half of what you did but tried to do so (only the powershell thing without extracting the driver because I know clearly nothing about that) But it did not worked, it was to be expected I did 1/2 the job.

    Even if the bluetooth driver was installed, my real problem after that will be the usb driver not working too, it's not a big deal, I'll take my time and wait for a W10 LTSC 1903 (if it ever happen), meanwhile I'll reuse Scp toolkit.
    Thank you for your help 🙂


  • I've just noticed that my Lenovo IdeaPad Craptop runs on 1809 still and it works, but I have to admit I had to do multiple installs for some reason. Maybe because of the Intel Integrated Card or some other weird reason, can't really put my finger on it. Since it works at least in one case I for now decided to not kick 1809 compatibility from the setup. Just so you know ☺