Wireless controller invisible unless I remove my DS4's HardWareIDs from AffectedDevices



  • More information!

    I installed DS4Windows 1.5.15 on m'laptop, also Windows 10 x64 build 17134.

    Exclusive mode does not work.
    Installed HidGuardian, and added the appropriate hardwareIDs to AffectedDevices in the registry. Just like on my desktop, the Bluetooth interface is able to connect to my wireless controller, but nothing appears under USB Game Controllers.
    I know that if it never shows up there before I've launched DS4Windows, then there's certainly nothing for it to hook onto, let alone for it to run in exclusive mode. Either way, looks like Exclusive Mode is straight up broke again -with or without HidGuardian.



  • Please disregard my last post.

    I removed my Hardware IDs from Affected Devices and tried again on my laptop.
    Exclusive mode DOES work on this laptop.

    So then what the heck is wrong with my desktop!?!?

    /me cries...



  • Exclusive mode is currently working on my desktop again!!!!!

    It may have been a combination of using 'devicescleanup' to get rid of everything, reconnecting via Bluetooth and then right-clicking ScpVBus.inf to install it before rebooting.

    I do not know exactly what fixed it, but I don't have to add my DS4 to AffectedDevices any longer. In fact, I'm about to uninstall HidGuardian because it shouldn't be necessary. Will check back.



  • Yup. HidGuardian is uninstalled, and I still have exclusive mode.

    Probably talking to myself by now, but hopefully someone can be inspired by my persistence. : )



  • OH FFS!
    It is failing to run in exclusive mode again!!!
    Is this going to get better..???



  • Indeed, I have to just stop/start DS4Windows until it finally works...
    This is the same crap I was doing a couple months ago until I figured out how to get HIDGuardian to work, but that doesn't work either.
    About to just go buy a f'ing Xbox One controller.



  • Seems to be a DS4Windows or SCPVBus issue then if HidGuardian is uninstalled.
    Not sure how to proceed with this very interesting predicament you have.



  • Well, thank you for at least chiming in Megadrago. I dunno, either. Sometimes I'll have to hit 'stop/start' like, 50 times before that stupid 'wireless controller' disappears from joy.cpl. I've got to figure something out for the long term because I want to be able to sign into Windows, turn on the controller, and launch any title in as few clicks as possible. I've learned how to write scripts for autohotkey, I've started to master the windows task scheduler, I've got batch files and shortcuts galore so that I can automatically configure the environment for the peculiarities of all these different titles. And yet I have to sit here and click click click click click click click just to get a single, accurate controller read-out. ...grumble, about to hit myself in the head with the business end of a claw-hammer.



  • If there is any additional logging from either windows, the event viewer, or DS4Windows that I can retrieve, let me know. I wonder if there is any additional logging or perhaps a debug mode that I can enable? So far, this whole thing just seems like a big giant black box for which we can only uninstall/reinstall and wonder.



  • Without HidGuardian and with a clean set of drivers I'd mentioned earlier, I've continued to fiddle with other things that required many reboots today. So far, I'm relatively happy to report that Exclusive Mode is achieved about 80% of the time. Heck, maybe it's fixed for the most part since the last update to DS4Windows. Maybe I'll never know if it's just my machine, or what causes the intermittent problems. : p


Log in to reply