Wireless controller invisible unless I remove my DS4's HardWareIDs from AffectedDevices



  • Hello all!
    I've been using (I think) a version 2 DualShock 4 in Exclusive mode after finally discovering that I need to add the appropriate hardware IDs to AffectedDevices in the registry. This has worked GREAT for the last month!

    Well, I came home last night, turned my DS4 on, and...nothing.

    The flashing light on the DS4 turned solid as though it was connected to my Bluetooth adapter, but there was no activity in Windows. No Wireless controller. No new devices in the Device Manager.

    Upon removing this hardwareID from AffectedDevices in the registry, my controller shows up again:
    HID{00001124-0000-1000-8000-00805f9b34fb}_VID&0002054c_PID&09cc

    The trouble is that Exclusive Mode hadn't worked unless that HardwareID was present!

    Was there a windows update or something? Is anyone else experiencing this?

    Thank you!!!



  • After re-reading my OP, I wanted to clarify. I know that the wireless controller is supposed to be hidden as soon as DS4Windows enumerates an Xbox controller from it. It's just that it's SO hidden that windows never ever sees it, let alone DS4Windows.



  • Hello and welcome to the forums!

    First: Which version of DS4Windows are you currently using along with OS type, EX: win 10 x64

    Second: Is DS4Windows set up to be whitelisted from being blocked in either it's settings or in the registry?

    This info is CRUCIAL for us to be able to help you out and getcha back to fragging!

    I also suggest looking at DS4Windows issue section (both open and closed) for similar posts and responses

    link: https://github.com/Ryochan7/DS4Windows/issues

    -M



  • Windows 10 x64.
    Newest and 2nd to last versions of ds4windows (reverted after issue emerged). Not home now, will get back with more detail. There's a whitelist setting in ds4windows? I saw the registry entry, but it's always blank. I'll try running as admin. Maybe that's what changed when I installed this last update cuz the changelogs said something about how startup is handled...
    God I hope I can get this working again, cuz I've been trying to configure my whole library for one click launching, and this messes up those plans...!



  • Okay, I'm back.
    DS4Windows Ver. 1.5.15 currently installed.
    I have 1.4.52 sitting in a backup folder.

    Additional detail to previous descriptions:
    My Bluetooth devices list is able to indicate that it is connected to my DS4 as a 'Wireless Controller' (switches between 'connected' or 'paired'), but it does not appear in the device manager, or in Windows' Game Controller list for so long as my HardwareIDs are present in the AffectedDevices registry string.

    In my previous post, I mentioned having seen a blank whitelist entry in the registry. Either I imagined it, or it's not there anymore after reinstalling HIDGuardian the last time. How do you add DS4Windows to the whitelist?



  • More information!

    I installed DS4Windows 1.5.15 on m'laptop, also Windows 10 x64 build 17134.

    Exclusive mode does not work.
    Installed HidGuardian, and added the appropriate hardwareIDs to AffectedDevices in the registry. Just like on my desktop, the Bluetooth interface is able to connect to my wireless controller, but nothing appears under USB Game Controllers.
    I know that if it never shows up there before I've launched DS4Windows, then there's certainly nothing for it to hook onto, let alone for it to run in exclusive mode. Either way, looks like Exclusive Mode is straight up broke again -with or without HidGuardian.



  • Please disregard my last post.

    I removed my Hardware IDs from Affected Devices and tried again on my laptop.
    Exclusive mode DOES work on this laptop.

    So then what the heck is wrong with my desktop!?!?

    /me cries...



  • Exclusive mode is currently working on my desktop again!!!!!

    It may have been a combination of using 'devicescleanup' to get rid of everything, reconnecting via Bluetooth and then right-clicking ScpVBus.inf to install it before rebooting.

    I do not know exactly what fixed it, but I don't have to add my DS4 to AffectedDevices any longer. In fact, I'm about to uninstall HidGuardian because it shouldn't be necessary. Will check back.



  • Yup. HidGuardian is uninstalled, and I still have exclusive mode.

    Probably talking to myself by now, but hopefully someone can be inspired by my persistence. : )



  • OH FFS!
    It is failing to run in exclusive mode again!!!
    Is this going to get better..???



  • Indeed, I have to just stop/start DS4Windows until it finally works...
    This is the same crap I was doing a couple months ago until I figured out how to get HIDGuardian to work, but that doesn't work either.
    About to just go buy a f'ing Xbox One controller.



  • Seems to be a DS4Windows or SCPVBus issue then if HidGuardian is uninstalled.
    Not sure how to proceed with this very interesting predicament you have.



  • Well, thank you for at least chiming in Megadrago. I dunno, either. Sometimes I'll have to hit 'stop/start' like, 50 times before that stupid 'wireless controller' disappears from joy.cpl. I've got to figure something out for the long term because I want to be able to sign into Windows, turn on the controller, and launch any title in as few clicks as possible. I've learned how to write scripts for autohotkey, I've started to master the windows task scheduler, I've got batch files and shortcuts galore so that I can automatically configure the environment for the peculiarities of all these different titles. And yet I have to sit here and click click click click click click click just to get a single, accurate controller read-out. ...grumble, about to hit myself in the head with the business end of a claw-hammer.



  • If there is any additional logging from either windows, the event viewer, or DS4Windows that I can retrieve, let me know. I wonder if there is any additional logging or perhaps a debug mode that I can enable? So far, this whole thing just seems like a big giant black box for which we can only uninstall/reinstall and wonder.



  • Without HidGuardian and with a clean set of drivers I'd mentioned earlier, I've continued to fiddle with other things that required many reboots today. So far, I'm relatively happy to report that Exclusive Mode is achieved about 80% of the time. Heck, maybe it's fixed for the most part since the last update to DS4Windows. Maybe I'll never know if it's just my machine, or what causes the intermittent problems. : p