SCP suddenly stopped working :/ (Windows Update?)

I've been using SCP Toolkit for a couple years now, sometimes it worked perfectly, sometimes it would just randomly stop starting on startup and had to Repair every single day.

It wasn't too bad but after doing some research I found some solutions mainly on your GitHub page but nothing worked for me. Now a few days ago I can't even repair the program anymore and my controller is not getting picked up by SCP Toolkit.

When I plug it in the lights flash for a while and I can hear the windows connection sound but when trying to repair I get an extremely long error message. I just tried reinstalling after completely deleting the program following the steps on GitHub. But after the Driver Installer it gives me another big error.

Screenshots of errors:

First one of the error messages translated -> 'the object reference is not set on an instance of an object'
The long one is reading something about authorization

Is there any way you could help me out with this information, or what more could I provide?
Thanks in advance

So I got reminded about an error whenever I try to close the SCP DSx Service. It shows the first error and another one shown in an image that I added in the Imgur gallery. Translation: Can't stop CP DSx Service on local computer. Error 109: The pipe has ended.

This also happens after trying to Repair or Reinstall the program

EDIT 2: I copied the installer files to my laptop, did the exact same process and the controller works perfectly ... I wanna cry. Is there a list of things that might interfere with SCP that I could check?

There's a few things you could try, I'll list them off in order from least time-consuming to most.

  1. You could try the "force driver installation" option.
  2. You could wipe SCPToolkit by uninstalling the program and following this guide: and retry installing it.
  3. You could wipe SCPToolkit from the system and try out the currently supported methods of controller emulation, a guide which can be found here:

Please note that the Shibari management layer, and Fireshock/Airbender drivers are still heavily under development. If you have any bugs related to Shibari or Fireshock, feel free to join the Nefarius Software Solutions Discord at Bugs regarding Airbender aren't the most useful at the moment at a successor is already in development.

Thanks for the reply, I tried the first one and everything goes perfect until the very end it gives me the big error.

The 2nd option I tried as well but I now I remember maybe another crucial message that popped up and could be worth mentioning so I'll edit my post.

Guess I'll give the 3rd option a try. Thank you 🙂

having trouble with that as well so Im gonna leave it. I don't get the Unblock button for the zip-files and when Installing the ViGEm Bus Driver it goes perfectly fine but at the end I get some red code which looks nothing like the example (After Get-ViGEmBusDevice )

So I tried the manual removal again and Im alittle confused with this "Now, if there's a node called Universal Serial Bus devices, expand it and repeat the un-installation steps for every device listed:"

Does it mean literally uninstalling all 11 objects in there? After the ':' I thought there would be a little list of some of the objects that I had to uninstall but had bugged out or something. They seem rather important/official so I just wanna be sure

After some more digging I realized something funny, the day before everything went to ... bad, there was a windows update. Please dont tell me ..............

I have SCPToolkit installed on my desktop machine at home, so I'll update it and see if it bonks anything on my end. And also "Now, if there's a node called Universal Serial Bus devices, expand it and repeat the un-installation steps for every device listed:" is only for the devices that are added when you plug in the control. Unplug and replug the controller, note which devices disappear and reappear. Uninstall those devices.

Ah I see, will give it another try. Thanks

For the record: the old article on manual removal looks weird without the screenshots because the original image hoster (Screencast from TechSmith) has shut down the free account hosting those images. A replacement article is in the works but unfortunately not yet done.

@nefarius Apart from that 1 sentence it was very clear to me 🙂 most confusion came from ':' signs so I thought there was some list missing. But now I understand

Yay, got another clue. I need GitHub Destop for school and earlier I installed it on my laptop without any problems. Now trying the same with my Desktop (which also has the SCP issues) and the installer instantly gives me an error:

And when I look at the logs they seem very similar to the ones I get from my SCP error thing (the long one).
Is this just coincidence or linked with each other?

EDIT: the next day I could install GitHub Desktop without any problems. SCP still giving me the errors

You don't need any Git tools for the SCO setup.

@nefarius No I needed it for school projects but when I tried installing it on my desktop, it gave me an error and it reminded me of the long error I get from SCP. It looked very similar, after a restart I could install GitHub-Desktop without any problems.

Would it be useful if I send you that error log and can I see SCP's error logs on my pc?

First you should clean your system before anything useful can be achieved. Follow both articles, it should point you in the right direction. From the screenshots multiple issues are possible so dealing with it one by one is important.

@nefarius what 'both articles' ? I did this a few times now, but I still get the error when trying to install again

I assume the ScpVBus driver can't be installed on your system. This is unfortunately not easily fixable.

thats a bummer, is that actually possible to happen from 1 day to another by itself or did I somehow mess up? As said, I can remember a windows update shortly before the errors started appearing but nothing else specifically

@nefarius Would a clean install of Windows fix this? Might reset my pc soon anyway to do some upgrades and maybe buy W10. (Im not sure if I factory reset if I'll go back to 8.1 or stay at 10)

Anyone please ?? Im getting crazy by not being able to use a damn controller. Why does this shit ALWAYS happen to me ...

You're always welcome to try out Shibari!

@daltz333 OMG thank you!! It finally works again. I tried installing this one before but got an error as well, no idea if I did something wrong or something in my pc changed but now it worked. My antivirus seemed to put the 'Shibari.Dom.Server' in quarantine when I fired it up again to enable automatic startup but it seems fine now, and I can easily restore it if needed